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Overview

Tutorial: Whole Genome Copy Number 
Association using CNAM and HelixTree

The Copy Number Analysis Module (CNAM), in conjunction with HelixTree, offers several methods for 
determining where regions of copy number variation occur and performing association analysis either on log2 
ratios directly or on found regions of copy number variation. 

This tutorial breaks down the overall approach into seven steps, each consisting of one or more processes. They 
are:

1. Generate log ratios versus reference samples

2. Identify markers to exclude

3. Correct for batch effects and stratification

4. Perform whole genome log ratio association tests

5. Run segmenting algorithm to generate segmenting mean values and covariate table.

6. Perform association analysis on copy number segment covariates

7. Visualize segmenting results

Depending on your particular dataset and research goals, it may not always be optimal to perform each step 
sequentially. To guide you, recommendations for how to proceed are provided at the end of each section.

TutorialGolden Helix SNP & Variation Suite
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Step 1. Generate Log Ratios Versus Reference Samples.

Before you can perform copy number analysis, you first need a DSF file containing log2 ratios (from now on referred to as 
LogRs) created by normalizing raw intensity data against a reference sample. CNAM offers direct support to create LogR 
DSF files from Illumina and Affymetrix platforms with additional functionality to create them from other providers. This tu-
torial will focus on preparing a LogR DSF file from Affymetrix CEL files. To learn how to create DSF files from Affymetrix CNT 
or CNCHP files, Illumina data or data from other providers, see section 4.4 of the HelixTree manual. 

The workflow CNAM uses to generate normalized LogRs from Affymetrix 500K, SNP 5.0 and 6.0 CEL files is analogous to 
the methodology employed by Affymetrix. However, CNAM can perform quantile normalization without gender bias, scale 
to handle thousands of samples, and allows greater flexibility in choosing a reference set. To learn more about how CNAM 
processes Affymetrix CEL files, see section 25.9 of the HelixTree manual.

Preparing Files Needed to Process Affymetrix CEL files

Before CNAM can process CEL files, the following are needed:

	 Spreadsheet matching NSP and STY (500K only)•	
	 Spreadsheet with CEL file names and column indicating reference status •	
	 Affymetrix marker maps•	
	 Affymetrix library files •	

Spreadsheet matching NSP and STY (for 500K only)
To properly process both the NSP and STY CEL files, a spreadsheet matching the two needs to be imported into HelixTree. 
This spreadsheet will tell the CEL import tool how to join the NSP and STY samples together to create one sample per 
patient in the DSF file. The matching spreadsheet must have a row label column and at least two data columns. The row labels 
must be the sample names. The first and second columns must be the NSP file names and the STY file names that are to be joined 
together, respectively. Other columns in the data set 
are optional and may contain the reference status 
for the sample. If you include the reference status in 
this spreadsheet, you can also use this spreadsheet 
to indicate reference status (see below).

The easiest way to import this file into HelixTree is to 
create a CSV file with respective columns and then 
select >File >Import Data >Import ASCII File from 
the project navigator window. Make sure to enter 
the Row Label Column Number representing your 
sample names.

Figure 1. ASCII File Import option with Row Label Column Number set to 1.
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The imported spreadsheet should resemble the image below.

Spreadsheet with CEL file names and column indicating reference status
This spreadsheet needs two columns, sample names (as row labels) and reference status. For the SNP 5.0 and SNP 6.0 Array, 
the row labels should be the file names of the CEL files with the “.CEL” extension removed. “0s” should denote samples to be 
used as references and “1s” should denote non-references.

Note: It is up to the researcher to finalize a reference strategy. In CNAM you 
can use any external or internal samples as your reference set. Affymetrix 
recommends using at least 25 samples as references in un-paired copy 
number analysis. As discussed later, if using an external reference set, these 
samples can be dropped from the corresponding DSF file.

As with the NSP and STY matching spreadsheet above, the easiest way to 
import this file into HelixTree is to create a CSV file and then select >File 
>Import Data >Import ASCII File from the project navigator window. 
Make sure to enter the Row Label Column Number representing your 
sample names. The imported spreadsheet should resemble the image to 
the left (Figure 3).

Affymetrix marker maps (annotation files)
You will need an Affymetrix marker map corresponding to the CEL files 
you wish to import. Probes not contained in the marker map will not be in-
cluded in the resulting LogR DSF file. For example, if the marker map does 
not contain copy number probes, those probes will not exist in the DSF file 
for copy number analysis.

The latest Affymetrix marker maps can be downloaded using the Affymetrix NetAffx service in HelixTree. To access this 
feature from the project navigator window, select >File >Import Data >Download Affymetrix Marker Map. You will 
be prompted for your Affymetrix NetAffx login information, which can be freely obtained by registering on Affymetrix’s 
website. After entering your NetAffx login information, the Download Annotations window will appear listing various 
Affymetrix annotation files (Figure 4).

Figure 2. Spreadsheet for matching files from the NSP and STY arrays for 500K analysis.

Figure 3. Reference status spreadsheet.
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It is important to note that there are actually two annotation 
files for each of the 500K, 5.0 and 6.0 files (500K = NSP + STY, 
SNP 5.0 and 6.0 = SNP + CN probes). For each file set, both 
corresponding annotation files need to be downloaded at the 
same time for HelixTree to properly merge them. To do this, 
highlight both annotation files (as seen in Figure 4), make sure 
the box Import into project when downloaded is checked 
and click Download. If you downloaded the annotation files 
previously, they should show up as a single merged file in the 
lower section of the window. If this is the case, you can just 
highlight that file and click Load Into Project.

Affymetrix library files
Similar to Affymetrix marker maps, Affymetrix library files can 
be downloaded using the NetAffx service in HelixTree. The 
library files should contain both SNPs and CN Probes when 
appropriate. 

To download library files, select the >Tools >Download 
Affymetrix Library File menu option from the project 
navigator window. After entering your authentication Figure 4. NetAffx marker map download window with both 

SNP 5.0 marker maps selected. information, HelixTree will load a list of library files available 
through the NetAffx service. To download library files, select 

one or more files from the upper window, and click Download. The file(s) will automatically be downloaded to the ../
HelixTree/AffyLibraryFiles directory.

Converting Affymetrix CEL files to LogR DSF File

From the project navigator window, select >CNAM >Import Affymetrix >Import CEL Files.

From the CEL file import dialog (Figure 5), first select the CEL files 
you want to include in the data set. For 500K data, you must select 
files from both the NSP and STY arrays for each sample. To select 
CEL files, click the Add CEL button, navigate to the appropriate 
folder and select multiple CEL files (you can hold down the Shift 
key to select multiple files at once).  The CEL files you selected 
will appear in the CEL import dialog window (Figure 6). You may 
add all of the CEL files in a directory by using the Add Directory 
button. This is especially helpful if you store your NSP and STY 
files in separate directories. To remove CEL files from the window, 
select the unwanted samples and click Remove Selected. You 
may continue adding CEL files by clicking the Add CEL or the Add 
Directory buttons again. 

Figure 5. The Affymetrix CEL File Import Dialog in HelixTree.

Figure 6. CEL files selected for conversion into a log2 ratio DSF file.
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For 500K CEL file import, next check the 500K NSP/STY Matching check box and select the matching spreadsheet 
previously imported to be used. If you are importing 5.0 or 6.0 CEL files, leave this box unchecked.

Next, select a spreadsheet containing the Reference Status for the samples. When a spreadsheet is selected, the 0=Ref 
1=Non-Ref Column drop down box will fill with the different binary data column names in the selected spreadsheet. 
Select the name of the column to be used as the reference status.

Note: The gender of the reference samples should be considered for copy number analysis of the X and/or Y chromosomes.

Check the box Don’t include reference sample in output Log R DSF if you are using external reference samples (e.g. 
HapMap data) and do not want them included in the resulting DSF file.

Next, select the Marker Map previously imported to be used in the analysis and choose the Library Path where the CDF 
library files for the appropriate array can be found. These reside in the directory where you previously saved them.

Note: After using the CEL import tool for your given array (500K, 5.0, 6.0), an AffyLibraryFiles directory will be created in the 
HelixTree installation directory containing *.gcdf library files. These files can be used from that point on instead of CDF files.

You have the option to specify a Temp Directory (Figure 10) where intermediate DSF files will be stored. If your project is 
located on a shared network drive (not recommended), you should specify a Temp Directory on a local disk. Finally select 
the Output LogR DSF location and click OK to begin the import. 

The conversion will take several minutes per CEL file to complete. The DSF file created is ready to be imported and analyzed 
using either the Copy Number Segmentation tool or the LogR Association Tests and PCA window.

From here you can proceed to Step 2: Identify markers to exclude, Step 3: Correct for batch effects/stratification, Step 4: 
Perform whole genome log ratio association tests, or Step 5:  Run segmenting algorithm to generate segment means and 
associated covariates.

Figure 10. Optional temporary directory and output DSF file name selected.

Figure 7. Selecting a spreadsheet to use for NSP and STY array matching.

Figure 8. Spreadsheet and spreadsheet column selected for determining reference status.

Figure 9. Marker map spreadsheet selected and library directory where CDF (or *.gcdf ) library files are located.
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It is sometimes desirable to filter out problematic markers before running segmentation, such as those with low call rates 
or gender-associated markers caused by effects of poorly randomized experiments. This tutorial will focus particularly 
on identifying gender-associated markers and creating a list of these markers to be excluded when performing LogR 
association tests and copy number segmenting (Steps 4 and 5). Other measures of quality control can be applied by 
following similar workflows.

To find gender-associated markers you need to perform an association test with gender as the dependent variable and 
LogRs as the independent variables. This can be done rather easily using the LogR Association Tests and PCA window in 
CNAM.

Select >CNAM >LogR Association Tests and PCA.

From this window, Browse to the LogR DSF File created in Step 1. You can then choose which Chromosomes you want 
to perform association tests on. In this case, select all chromosomes – this will be the default if your LogR DSF contains 
information for all chromosomes. Then, Check the association tests you would like to perform. 

Next, you need to select a spreadsheet within HelixTree containing your phenotype information - gender in this case. If you 
have not already imported your phenotype spreadsheet, from the project navigator window go to >File >Import Data and 
choose either >Import Wizard or >Import ASCII File. Make sure to indicate the column with your sample names as the 
row label column. This will ensure each sample’s gender status is appropriately matched to its LogRs when performing the 
association test. 

Once your phenotype spreadsheet is imported into HelixTree, from the LogR Association Tests and PCA window click 
Choose Spreadsheet, select the appropriate phenotype spreadsheet and click OK. 

Having selected a phenotype spreadsheet, the Quantitative or Binary Trait box will be activated. Scroll down and select 
the gender column to make it the dependent variable. 

Step 2. Identify Markers to Exclude.

Figure 11. LogR Association Tests and PCA window.
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Figure 13. P-value plot representing gender-associated markers.

Now you can perform association test(s) on gender. You may also simultaneously correct for batch effects or stratification 
using principle component analysis. This will be covered in Step 3, so for now Uncheck the Correct for Batch Effects/
Stratification with PCA box. Click Run.

The result is a spreadsheet with markers as rows and p-values for each test statistic as columns (Figure 12). 

Note: The p-values in this spreadsheet are not Bonferroni corrected.  

You can plot each column to visually inspect the markers associated with gender by Left Clicking on the column number 
and selecting Plot this Column. You should see a plot similar to Figure 13 with significant peaks across the genome, 
signifying gender-associated markers.

Now you need to create a row subset spreadsheet of only those markers whose p-values are less than a given cutoff (e.g. 
.01). 

To do this, first go back to the p-value spreadsheet, Left Click on the column number again and this time select Sort 
Ascending. Scroll down to the first marker that exceeds your cutoff p-value and Left Click that marker’s row label once. 

Figure 12. P-value spreadsheet that results after performing LogR association tests.
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This will turn the entire row grey, which means it is now inactive. To inactivate the rest of the markers above the cutoff, hold 
down the Shift key, scroll to the bottom of the spreadsheet and Left Click the last marker’s row label. All markers greater 
than the p-value cutoff should now be inactivated, and all markers less than the cutoff should be activated (Figure 14).

Next, from the spreadsheet menu, select >Edit >Row 
>Subset Spreadsheet. This will create a new spreadsheet 
with only the markers below the p-value cutoff (or those 
activated in the original spreadsheet). Finally, export 
this spreadsheet as a CSV file by selecting >File >Save a 
Comma-Delimited Text File. Browse to a path where you 
want the CSV file saved and click Save. 

Next, you need to delete all the columns in the CSV file 
except for the first containing the marker names. This can 
be done easily within Excel or other spreadsheet editing 
programs.  Once you have a CSV file with a single a column 
of marker names, it can be used in Steps 4 and 5 to exclude 
markers when performing LogR association tests and copy 
number segmenting.

You can now proceed to Step 3: Correct for batch effects/
stratification or skip to Step 4: Perform whole genome LogR 
association tests or Step 5:  Run segmenting algorithm to 
generate segment means and associated covariates.

Figure 14. Inactivating markers greater than p-value .01. 
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Sometimes, finding an association can be confuted by population stratification. This is because a condition may be more 
prevalent in one group of samples than in a different group, and therefore there will be a spurious association between the 
condition or trait being tested for and any genetic characteristics varying between the two different groups. 

While it is good practice for studies to be based upon the most homogenous test subjects as possible, it has been noted 
that even those who classify themselves as “Caucasian” have mild variation in genetic characteristics problematic enough 
to confound a study done over thousands of genetic markers.

Additionally, it has been our experience, especially with copy number analysis, that there is evidence of variations in 
test equipment confounding studies. These are referred to as batch effects, which are often the result of improperly 
randomizing the genotyping of cases and controls, males and females, etc. For example, perhaps all cases (or all females) 
were done at one site or day and controls (or males) at another. 

This tutorial will lead you through correcting LogRs for batch effects and stratification using an Eigenstrat-based principal 
component analysis (PCA) method. The result will be a new DSF file with PCA corrected LogRs. This file can then be used to 
perform LogR association tests or copy number segmenting (Steps 4 and Step 5).

Determining How Many Principle Components to Use

Before you apply PCA to your LogRs, you need to determine how many principal components to use in the analysis. 
Determining this is to some degree an open question. First off, if you choose as many components as there are markers, 
you will wind up subtracting out ALL effects, thus getting nothing from your tests.

A better option is to determine the components themselves with their corresponding Eigenvectors and then look at the 
pattern of the Eigenvalues. 

To do this, from the project navigator window select >CNAM >LogR association tests and PCA. 

Note: From this window you can also perform LogR association tests (Step 4) at the same time as correcting for batch 
effects or stratification. This tutorial will treat each step separately.

Step 3. Correct for Batch Effects and Stratification

Figure 15. LogR Association Tests and PCA window ready to perform 
PCA analysis on LogR DSF file.
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From this window, Browse to the LogR DSF file created in Step 1 and click Open. Notice by default all the chromosomes 
will appear in the box below the input DSF file location. Only those chromosomes appearing here will be corrected. 

Note: Including the X chromosomes may result in an erroneous systematic shift of the data, so we recommend excluding 
them from PCA analysis and adjusting the first 22 chromosomes. To do this click Chromosomes, uncheck ‘X’ and click OK.

Since you are not performing association tests during this step, Uncheck the three association test boxes. Also Uncheck 
the Correct Batch Effects/Stratification with PCA box since you first need to learn how many principal components to 
use before applying PCA. 

Next, click on the Principle Component Analysis Parameters tab. 

In this tab enter the number of principal components you want CNAM to find. For this first pass analysis, you should choose 
to find more than you believe are necessary. Beware that the more you enter, the longer the analysis will take. Next, check 
the Output Separate Spreadsheet of Eigenvalues box. For the purpose of this tutorial, do not worry about PCA Outlier 
Removal. Click Run.

When the analysis finishes, two spreadsheets are created, one containing Eigenvalues (Figure 17a) and the other principal 
components (Figure 17b). At this point, you are still deciding how many principal components to use, so you can delete the 
principal component spreadsheet.

Figure 16. Principal Component Analysis Parameters tab set to find 100 principal components.

Figure 17a. Eigenvalues spreadsheet.

Figure 17b. Principal component spreadsheet.



11

From the Eigenvalue spreadsheet, which contains one column of Eigenvalues, Left Click on the column number (1) and 
choose Plot this Column. You should get a plot similar to Figure 18.

Though there is currently no optimal way to decide 
how many principle components to use, if the first 
few Eigenvalues are very large compared with the 
remaining Eigenvalues, then a reasonable guideline 
is to use that many components in the second 
analysis when applying the PCA technique. In Figure 
18, notice how the size of the Eigenvalues begins to 
smooth out around 10. Using more than nine may 
result in diminishing returns and may even adversely 
affect the results.

Note: For a more thorough discussion of 
stratification, principal components analysis, and 
Eigenvalues see: 

Price, Alkes L., Patterson, Nick J. Plenge, Robert M. Weinblatt, 
Michael E. Shadick, Nancy A. Reich, David. (2006). Principal 
Components Analysis Corrects for Statification in Genome-
Wide Association Studies. Nature Genetics 38, 904-909.

Patterson N, Price AL, Reich D (2006) Population Structure and 
Eigenanalysis. PLoS Genetics 2(12): e190. doi:10.1371/journal.
pgen.0020190. 

Applying PCA Correction

Now that you have determined the number of principle components to use, you can go back into the LogR Association 
Tests and PCA window to correct for batch effects and stratification.

Again, Choose the DSF file you want to correct and Uncheck all the association test boxes. 

Next, make sure the Correct Batch Effects/Stratification with PCA box is checked this time. 

You also need to check Output the PCA adjusted logRs to a DSF. This allows you to import and segment the PCA 
corrected data using the Copy Number Segmentation window (Step 5), or use it as the input DSF in this window to run 
LogR association tests (Step 4) without having to re-run PCA correction each time. Browse to the path where you want to 
save the corrected DSF, name it and click Save. 

Note: It is good to give the DSF file an intuitive name, such as one referring to the number of principal components used. 
The corrected LogRs will differ depending on how many principal components are used.  

Click on the Principal Component Analysis Parameters tab.

Here you need to enter the number of principle components you determined previously. This time it is not necessary to 
output the Eigenvalue spreadsheet so you can Uncheck this box. Again, for this tutorial don’t worry about PCA outlier 
removal. 

Next, click on the Exclude SNPs tab.

From this tab, you can now exclude the markers you identified in Step 2. Browse to the CSV file created in Step 2 and click 
Open. A list of markers from the CSV file should now be listed as in Figure 19.

Figure 18. Plot of Eigenvalues.
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When you are finished, click Run. 

The result for this particular analysis is a new DSF file containing PCA 
corrected LogRs minus the excluded markers and a secondary principal 
component spreadsheet.

From here you can proceed to perform LogR association tests (Step 4) 
or perform copy number segmentation (Step 5) on the corrected DSF.  

Figure 19. Exclude Markers tab.
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It is advantageous to perform association directly on LogRs prior to running copy number segmentation (Step 5) because 
the computation time is much faster and it provides a good first look at the data. Please note however, the number of 
LogRs will be much greater than the number of copy number segment covariates resulting in a greater multiple testing 
penalty.

You can perform LogR association tests on any LogR DSF 
file. We recommend first correcting for batch effects and 
stratification and filtering out problematic markers as 
covered in Steps 2 and 3. 

Note: LogR association tests can be performed 
simultaneously while correcting for batch effects and 
stratification and excluding problematic markers, all from 
the same window. This tutorial works through performing 
each process separately. 

To get started, from the project navigator window select 
>CNAM >LogR Association Tests and PCA. In this 
window (Figure 20), Browse to the PCA corrected LogR 
DSF file created in Step 3 and select the Chromosomes 
you want to test. Check the box next to the association 
test(s) you want to run.

Next, you need to select a spreadsheet within HelixTree 
containing your phenotype information, in this case, 
case-control status or quantitative trait. Your phenotype 
spreadsheet should have already been imported during 
Step 2. If you have not already imported your phenotype 

spreadsheet, from the project navigator window go to >File >Import Data and choose either >Import Wizard or >Import 
ASCII File. Make sure to indicate the column with your sample names as the row label column. This will ensure each 
sample’s phenotype status is appropriately matched to its LogRs when performing the association test(s).  

Once your phenotype spreadsheet is imported into HelixTree in the LogR  Association Tests and PCA window, click Choose 
Spreadsheet, select the appropriate phenotype spreadsheet and click OK. A list of all quantitative and binary variables in 
the phenotype spreadsheet will now appear in the next box. Select the variable you want as your dependent.

Because the DSF file selected above already contains PCA 
corrected LogRs, uncheck the Correct Batch Effects/
Stratification with PCA box. This will inactivate all PCA 
related options, including the parameters on the next tab. 

If you wish to exclude other markers than those already 
excluded in Step 3, go to the Exclude Markers tab, 
Browse to the CSV file with the additional markers and 
click Open. 

You are now ready to perform association. Click Run. 

The result will be a p-value spreadsheet (not shown) 
with all the marker names in the first column and their 
corresponding p-values in each additional column. 

You can plot each column by Left Clicking on the column 
number and selecting Plot this Column.

Step 4. Perform Whole Genome Log Ratio Association Tests.

Figure 20. LogR Association Tests and PCA Window.

Figure 21. P-value plot from t-tests on PCA corrected LogRs.
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In some cases, there may still be spurious associations across the genome (as seen in Figure 21). To reduce some of the 
noise you can apply a Median Smooth script to the p-values of each column. The Median Smooth script calculates a 
moving median centered about a given observation plus/minus a user-defined window size. This script is not provided 
with the software but can be downloaded from our online script repository.

http://www.goldenhelix.com/SNP_Variation/scripts/index.html

To use the Median Smooth script, Download the mediansmooth.py file from the webpage above and Save it in your ../
HelixTree/scriptsht/spreadsheet/edit/ directory. Next, from the p-value spreadsheet select >Edit >Median Smooth. A 
dialogue window will appear asking for a moving window size (Figure 22). 

Enter an appropriate window size (i.e. 3) and click OK. 

Note: A window size of 3 would include 7 observations
The result is a new p-value spreadsheet with the original p-value columns and new median smoothed p-valued columns. 
You can again plot each column by Left Clicking on the column header and selecting Plot this Column. 

You should see far fewer spurious associations in a smoothed plot (Figure 23) versus an unsmoothed plot. 

By Left Clicking and Dragging on the plot you can zoom into a region. Zooming in on a significant spike (Figure 24) 
should reveal a region spanning several markers with multiple significant p-values.

Figure 23. Plot of median smoothed p-values.

Figure 22. Median Smooth script with a 3 marker window size.
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A quick way to determine where significant markers 
reside on the genome and what genes they are 
associated with is to join the p-value spreadsheet 
with a marker map containing these markers. Such 
a marker map was imported in Step 1 and should 
already be in the project. 

To do this, go back to the Median Smoothed p-value 
spreadsheet and select >File >Join Spreadsheets 
on Row Labels. Select the appropriate marker 
map spreadsheet and click OK. The result is a 
spreadsheet with marker names, p-values and 
marker map information.

From here you can go to Step 5 to run the Golden 
Helix segmenting algorithm on only those 
chromosomes revealing significant LogR association 
results or the entire PCA corrected LogR DSF. 

Figure 24. Zoomed p-value plot of ~10 marker significant peak.
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CNAM employs an optimal segmenting algorithm that utilizes dynamic programming to exhaustively search through all 
possible change-points in LogR data to discover regions of markers in which LogRs vary significantly from region to region. 
These regions will generally be where there is copy number variation in your data.

The segmenting process is optimized by working at three levels:

   1. If desired, the region of markers is subdivided into a moving window of sub-regions.
   2. �A unique segmenting algorithm is applied to find multiple segments wherever possible, and by implication, 

segment boundaries which we term “cut-points”.
   3. A permutation algorithm is applied to validate the found cut-points.

CNAM offers two types of segmenting methods, univariate and multivariate. These methods are based on the same 
algorithm, but use different criteria for determining cut-points. The multivariate method segments all samples 
simultaneously, finding general copy number regions that may be similar across all samples. This method is preferable 
for finding very small copy number regions, and for finding conserved regions that may be useful for association studies. 
For a given sample, the covariate is the mean of the LogRs within each segment for that sample. If there are consistent 
positions for copy number variation across multiple samples, the copy number segments will be found. In reality, there may 
not always be consistent copy number segments across multiple samples. The univariate method segments each sample 
separately, finding the cut-points of each segment for each sample and outputting a spreadsheet showing all cut-points 
found among all samples.

This tutorial will focus on performing multivariate segmentation. The result will be two spreadsheets. The first is a copy 
number segment covariate spreadsheet which contains the mean LogR value for each sample within each segment of 
markers. The second is a segment means spreadsheet which contains columns for the chromosome number, segment start 
position, segment end position, segment mean, and the segment length in number of markers. Optionally, a Wiggle file 
may also be generated with found regions and can be viewed using a supported genome browser.

Performing Copy Number Segmentation

From the project navigator window, select >CNAM >Copy 
Number Segmentation. The window at (Figure 25) right will 
appear. 

As with LogR association tests, you can perform segmentation 
on any LogR DSF file, though we recommend first correcting 
for batch effects and stratification and filtering out problematic 
markers as was done in Steps 2 and 3. 

Browse to the LogR DSF file created in Step 3 and select the 
Chromosomes you want to segment. 

Note: Segmentation takes a fair amount of time to run. You 
may want to start with only those chromosomes that showed 
interesting regions from the LogR association tests in Step 4.

The next section, Import Options, can be somewhat confusing. 
There are two options, Import Segmenting Results or Import 
Raw Data. These are asking whether you want to import the 
results of the segmentation performed in this step into HelixTree 
or simply the LogRs of the DSF selected above. Notice if you 
select Import Raw Data, all the segmentation options below will 
be inactivated because segmentation will not be performed. 

Step 5. Run Segmenting Algorithm to Generate Segmenting Mean Values and 
Covariate Table.

Figure 25. Copy Number Segmentation window.
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Why import the raw data into HelixTree? Importing the raw data will enable you to perform tree-based association on the 
LogRs rather than the copy number segment means. With a few minor workarounds you can also visualize copy number 
segments directly in HelixTree rather than with an external genome browser. 

Importing raw data into HelixTree is not covered in this tutorial. If you want to perform this operation, it is recommended 
that you either create a smaller DSF file based on a smaller sample size in Step 1 or only import a single chromosome at 
time. This is necessary because LogRs cannot be sparsely stored like SNP data, resulting in a spreadsheet that may exceed 
available computer RAM causing the program to crash. For this reason, we developed the LogR association test and PCA 
window as covered in Step 4.

Select Import Segmenting Results.

The next section, Chromosome Segmenting Options, allows you to choose which method you want to use for 
segmenting (multivariate or univariate) and to optimize the speed of the analysis. For the purpose of this tutorial, select 
the Multivariate algorithm and leave the rest of the parameters as the default values. For more information about these 
parameters, see section 25.3.4 of the HelixTree manual.

Next, click on the Optional Output tab. Check the Optional Bookmark File Output box if you want to export the segment 
means to a UCSC Wiggle Track (WIG) format file. WIG files allow you to view segment results in supported genome browsers 
such as UCSC’s Genome Browser and Affymetrix’s Integrated Genome Browser (IGB). Viewing segment results in UCSC’s 
Genome Browser will be covered in Step 7. 

Note: If you are considering using UCSC’s Genome Browser, be aware there are limitations affected by the parameter 
settings in this step. Please see Step 7 before proceeding.

Enter a file name and Browse to a path where you want to save the WIG file and click Save. 

Note: If outputting WIG files while using the univariate segmenting algorithm, the browse button will have you select a 
directory location because a WIG file will be generated for each sample. These files will be named using the sample name.

If you wish to exclude additional markers other than those already excluded in Step 3, go to the Exclude Markers tab, 
Browse to the CSV file with the additional markers and click Open. 

You are now ready to run segmentation. Click Run. 

When segmentation has completed, two spreadsheets 
will pop up. The first is a copy number segment 
covariate spreadsheet (Figure 26), which contains 
the mean LogR value for each sample within each 
segment of markers.  The second is a segment means 
spreadsheet (Figure 27), which contains columns 
for the chromosome name, segment start position, 
segment end position, segment mean, and the 
segment length in number of markers. If you selected 
to output a WIG file this will be stored at the path you 
chose above.

From here you can visualize found copy number 
segments in a genome browser (Step 7) or move on to 
performing association analysis on the copy number 
segment covariates (Step 6).

Figure 26. Copy number segment covariate spreadsheet.

Figure 27. Segment means spreadsheet.
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The next step is performing association analysis on the copy number segment covariates identified in Step 5. To do this, 
you first need to join the copy number segment covariate spreadsheet with your phenotype data. 

Your phenotype spreadsheet should already be in HelixTree from Step 2. If you have not already done so, from the project 
navigator window go to >File >Import Data and choose either >Import Wizard or >Import ASCII File. Make sure to 
indicate the column with your sample names as the row label column. This will ensure each sample’s phenotype status is 
appropriately matched to its copy number segment data when performing the association test(s). 

Open your phenotype spreadsheet and select >File >Join Spreadsheets on Row Labels. Select your copy number 
covariate spreadsheet and click OK. A new spreadsheet will be created (Figure 28) with your sample names as row labels 
followed by each sample’s phenotype information and then its mean LogR value for each segment.

Performing association analysis on this 
spreadsheet is done using the classic tree-
based analysis approach in HelixTree. To do 
this, from your joined spreadsheet, first Left 
Click once on the column header of your 
dependent variable. This will turn the column 
magenta indicating its dependent variable 
status. You can also Left Click twice on the 
column header of each non-copy number 
segment column header to turn it grey. This 
will inactivate these columns so they won’t be 
used during analysis. If you want to include 
them, leave them black. 

Next select >Analysis >Interactive Tree Analysis. 

A window (Figure 29) with a single box (referred to as the root node) will 
appear and display the number of samples in your data set (n), the mean 
value of the response variable (u), and the response variables standard 
deviation (s). From this window you can either perform tree-based 
segmenting or regression association analysis. 

Note: This tutorial only covers basic tree and regression analysis. To learn 
more about advanced capabilities of tree analysis see Chapter 7 in the 
HelixTree manual.

Tree-Based Segment Association 

Similar to how the segmenting algorithm works in CNAM to identify copy 
number variations from LogRs (Step 5), HelixTree employs segmenting to 
find the optimal split(s) in a dataset whereby the mean(s) of the resulting 
subgroups differ based on a given variable (e.g. mean intensity values for 
a given marker). HelixTree then performs the appropriate association test 
to determine whether the differences in means among the subgroups are 
statistically significant. 

HelixTree is unique in that can use this segmenting association approach 
to find multi-way splits supported by the data. This is especially powerful 
when considered in the context that a deletion or duplication is a 

Step 6. Perform Association Analysis on Copy Number Segment Covariates

Figure 28. Simulated joined phenotype and copy number segment covariate 
spreadsheet.

Figure 29. Interactive Tree Analysis root node: 
n = 500 samples, u =  62% cases, s = standard 
deviation of .48.
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disruption, and a disruption may lead to higher incidence of disease.  In cases where a basic test of association, such as 
regression and t-tests, may not find anything, a multi-way split may find that patients with a segment mean LogR near 0 
(copy number two) may have a lower incidence of disease than patients with a higher or lower mean LogR (the tails). 

To perform basic tree-based segment association, Right Click on the root node and select Manual Split. This will pop 
up the Manual Split window (Figure 30) with a list of p-values, the copy number segment covariates (referred to here as 
splitters), and the split rule used to perform the association.

Clicking on each row of the Manual Split window will change the tree view to reflect the various split rules. Clicking on 
Plot P Values by Var # will plot the p-values for each segment covariate, which will produce a p-value plot similar the ones 
created in Step 4. 

You can visualize the association results for each splitter by clicking Define Split at the bottom of the Manual Split window. 
This will plot the segment mean LogR values against the response variable. For copy number segment association, you will 
typically see a plot with a binary (two-way) or three-way split (denoted by one or two vertical lines respectively). 

Figure 31a, shown below, displays a binary split. Notice how the plot is centered around zero on the X-axis. This is because a 
LogR of zero is equivalent to copy number two. A rudimentary interpretation of this plot is that on average, a copy number 
equal to or less than two will result in a reduced incidence of disease (control), whereas a copy number variation greater 
than two will result in a greater incidence of disease (case).

Figure 31b, shown below, is a screenshot of a three-way split. The interpretation of this plot is that on average, a copy 
number less than or greater than two will result in a greater incidence of disease (case), whereas a copy number variation 
equal to two will result in a reduced incidence of disease (control).

If you see a plot where the LogRs go from low to high or high to low, there is a good chance an additive affect is taking 
place. In this case, it would be best to perform regression association.

Figure 30. Manual Split window highlighting significant region Chr1:210-216 with F-Test 
Bonferroni corrected p-value (bP) of 1.15E-10. 

Figure 31a. Binary split. 	 Figure 31b. Three-way split. 
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Tree-Based Regression Association

Regression association is also performed using interactive tree analysis with a modification to one of the tree options. 
To perform regression, go back to your joined phenotype/copy number segment covariate spreadsheet. Make sure your 
response variable is still magenta and select >Analysis >Interactive Tree Analysis. This will again pop up the tree view 
with a single root node. From this window select >Tree >Options. The following window will appear.

Toward the middle of the window there is a check box Linear/Logistic Regression. Check this box. This will enable 
regression to be performed from the Tree View. 

Note: Based on your response variable, HelixTree will automatically perform a linear regression for quantitative dependent 
variables and logistic regression for binary dependent variables. 

Click OK.

Now from the root node in the Tree View, Right Click and select Manual Split.  A similar window to Figure 33 will appear.

Figure 32. Tree options with Linear/Logistic Regression selected.

Figure 33. Manual Split window highlighting significant region (Chr1:163-171) with regression based 
Bonferroni p-value (bP) of 5.22E-05.
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Notice now there are regression Split Type’s and the split rule is equivalent to the regression equation. The p-values are also 
different because they are now based on a regression test.

Click Create Split. This will drop a residual node in the Tree View. (Figure 34). Notice the mean (u=) in the residual node is 
now zero. From here you can plot the association results by Right Clicking on the root node and selecting >Visualize Split 
Data >Show Split Data. 

A plot similar to that in the Define Split window will appear (Figure 35).

From here you can repeat Step 5 and segment additional chromosomes or visualize interesting regions in an external 
genome browser (Step 7).

Figure 34. Residual node from regression “split” with option to view as-
sociation results (split data).

Figure 35. Regression association results.
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There are tools available outside HelixTree to visualize your copy number segmenting analysis results. Using the optional 
wiggle track file output in Step 5 you can view your segmenting results using UCSC’s Genome Browser or Affymetrix’s 
Integrated Genome Browser (IGB). If you are analyzing Illumina data you can output the Segment Means spreadsheet 
created in Step 5 as a bookmark CSV file to view your results in Illumina’s BeadStudio Genome Browser. This tutorial will 
cover importing data into UCSC’s Genome Browser. For more information on the other browsers see section 25.6 of the 
HelixTree manual.

The UCSC Genome Browser is an online tool created by the University of California, Santa Cruz (http://genome.ucsc.edu/
cgi-bin/hgGateway), used to view genome data formatted in the Wiggle track format (WIG).

To import copy number analysis results in the UCSC Genome Browser, first go to the website address above. Select the add 
custom tracks button to open the add custom tracks page. From this page browse for the WIG file created in Step 5 and 
select Submit. The next page will have a table to view the tracks found in the specified WIG file. To add more data tracks 
(samples), select add custom tracks. To view the tracks in the genome browser (Figure 36), select go to genome browser.

Note: There are some restrictions on the data that can be imported into the UCSC Genome Browser because it is an online 
tool. When performing multivariate segmenting analysis in CNAM, the results may contain segments that are only one 
marker in length. The UCSC Genome Browser does not accept data files containing segments with length equal to one. To 
avoid this conflict, in Step 5 set the Min #Markers per segment parameter in the Copy Number Segmentation tool to a 
value greater than one.

The second conflict when using the USCS Genome Browser to view CNAM segmenting results occurs when the difference 
between a segment’s chromosome start position and chromosome end position is found to be larger than 10,000,000 bp. 
Currently the best way to handle this issue is to manually separate the large segments into multiple adjacent segments 
with the same segment mean. The WIG file can be opened and edited in a text editor. Following the format outputted by 
CNAM, insert rows to divide the long segment into multiple shorter segments.

Step 7. Visualize Segmenting Results

Figure 36. UCSC Genome Browser showing HelixTree segmenting results.




