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How do I log in and enter a license key? 
■ From the VarSeq welcome page, click on the 

Register tab and fill in the required information, 

read and accept the license agreement (EULA) and 

click Register & Log In. 

■ Once you are logged in, if you have not already 

activated a license key, or if you have reached the 

limit of activations available, you will be in VarSeq 

viewer mode. 

■ To activate a license key, click on Activate License 

Key in the lower right hand corner of the welcome 

page, or go to Help > Activate a VarSeq License 

Key. Enter in the provided license key and click 

Verify. If there are any available activations, click 

Activate. 

How do I start a project? 
■ Click on a sample project shipped with VarSeq. 

They will be listed on the VarSeq welcome page or 

in File > Open Example Project. 

■ To create a new project, click on Create New 

Project. 

■ Select a project template from the list of existing 

templates. Information about each template will be 

displayed on the right. 

■ Verify the Genome Assembly matches the 

assembly used to align your data and specify a 

project name and location to save your project. 

■ An empty template can be used to create a new 

workflow. This is an advanced option. 

■ To open an existing project, either click on Open 

Existing Project, or select the project from the list 

of recent projects. 

How do I add data? 
■ You can import one or more variant files into a new 

project. VarSeq also supports annotating from 

numerous other file types. 

■ If your project was created from a template, the 

Import Variants dialog will automatically appear 

after creating a new project. Otherwise, you can 

click on the Import Variants button and select one 

or more files to import. 

■ Once the files have been selected, compressed and 

indexed you will be prompted to edit the sample 

information. You can change the sample name, 

affection status, and if the samples are related, set 

the parents for the children. Sample information 

can be imported from a text file. BAM files can be 

linked to sample data for coverage statistics. 

■ Once the variants have been imported you may 

annotate the variants using annotation sources, or 

run a computation algorithm on the variants using 

sources already added. 

How do I annotate my variants using existing 

sources? 
■ From the main tool bar, click on the  button 

and select Annotation…. Choose the annotation 

source and then click Select. All imported variants 

will be annotated against the selected source. 

How do I run an algorithm on my data? 
■ From the main tool bar, click on the  button 

and select Computed Data…. On the left is a list of 

possible computation algorithms. Select the 

desired algorithm and click OK. Follow the prompts 

to add in the required parameters for the 

algorithm. 

How do I change the samples visible or how 

the sample data is collated in a table? 
■ To change the samples visible or how the sample 

data is collated in a table, click on the sample 

display options icon   and adjust either the 

Collated By or the visibility option for the samples. 

■ If the samples were imported with family 

information or tumor/normal pairs you have the 

option of only showing the current sample and 

linked samples (Current and Parents or Tumor and 

Normal). Otherwise these option are not available. 
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How do I change which columns or fields are 

visible in a table? 
■ Click on the Hide/Show icon.  Entire groups of 

columns fields can be hidden or shown by toggling 

the check boxes. 

■ Expand each group to select particular fields to hide 

or show. 

■ Click on Select All or Unselect All either by a 

column group name or below all of the column 

groups to toggle the selection of more than one 

field at a time. 

How do I sort data in a column? 
■ To sort data in a column, right-click on the column 

header and select one of the sorting options. 

■ To unsort the data, right-click on any column and 

select Sort in Genomic Order. 

How can I visualize data in a particular filter? 
■ Click on the number of variants on the Filter Card 

and the table view will show the results of that step 

in the filter chain. 

■ To view the variants as they pass through each 

filter card, click on the Expand button on a 

particular card. The highlighted categories 

generally display the number of variants that pass 

the criteria specified by the card. Clicking on any of 

the numbers in the filter card will display those 

variants in the table view. 

■ Right-click on any filter card and select either 

Results Up Through This Filter or Results For 

Only This Filter. 

The difference between result display options 

Results Up Through This Filter 
Selecting this option displays all variants that remain in 

the Filter Chain after applying the current filter. This 

means the particular filter criteria and all previous filter 

criteria have been met for the variants displayed in the 

Table View. 

Results For Only This Filter 
Selecting this option displays all variants from the 

original set of variants that meet the filter criteria of 

only the current filter. 

How do I export data? 
■ Go to File > Export or click on the export 

button  and select the format to export the data to. 

■ To export the data as a VCF file, you will need to 

select the fields in the table to export. By default 

only the fields visible in the table will be selected 

for export. Additional fields can be added by 

selecting them in the list of fields to export. 

■ To export the data to an Excel workbook, specify a 

file name. All selected tables will be exported into 

one workbook with one tab/sheet per table. 

■ Data can also be exported to a delimited text file or 

as an annotation source (TSF file). 

NOTE: Only the variants present in the table(s) will 

be exported, respecting any applied filters. 

How do I change the sample in the project? 
■ To quickly reprocess the filter chain for new 

samples, you can use the arrow keys on either side 

of the current sample menu to switch samples.  

■ To navigate through all samples in the project, click 

on the down arrow or right click in the current 

sample menu and select Show All then click on the 

right or left arrows or click on the down arrow and 

select a sample.  

■ To change the current sample, select the sample 

from the drop down menu.  

How do I add a filter card to the filter chain? 
■ To add a filter card for a particular column or field in 

a table, right-click on the column and select Create 

Filter Card for this Column. 

■ To add a filter card to an existing filter container, 

right-click on the column to create a card and click 

on the created filter card and drag and drop the 

card into the desired container or position. 

■ You can also add a filter card or filter container by 

right clicking anywhere in the filter chain or on an 

existing container and selecting either Add Filter or 

Add Filter Container. 

How do I mark variants in the table view?  
■ First create a record set by clicking on the 

Record Sets button  and then click on the 

box for the particular variant you want to mark. 



 

© 
 

 

      © 2015 Golden Helix, Inc. 3 

■ To mark all current variants in a table select Set 

to Current Variants in the record set’s sub-

menu. 

■ To add all current variants in a table to an 

existing record set select Add Current Variants 

in the record set’s sub-menu. 

The difference between cards and containers 

Filter Card 
A filter card contains instructions on which variants to 

keep based on criteria specific to a single column or 

field of data. 

Filter Container 
A filter container can contain one or more filter cards 

and should be used for grouping filter cards together to 

create advanced criteria for determining which variants 

should pass the filter criteria. 

How do I hide or stash a view? 
■ Click on any gray X in the corner of any tab. This 

will delete the view but it can be restored at any 

point with the existing settings. 

■ To stash a view, hover over one of the four corners 

of the window until the stash icon appears, for 

instance the icon in the upper left corner is:  . 

Click on the icon and the tabbed view(s) closest to 

that corner will be stashed. 

How do I rearrange the layout of tabs? 
■ Tabs (or views) can be rearranged like tabs in 

modern web browsers. Just click on a tab and drag 

and drop on an existing view to stack the tab, or 

hover over an edge of the window. If a placement 

hint appears, the tab can be dropped in that 

location. 

■ You can take advantage of multiple monitors by 

ripping tabs out of the main window and creating 

new windows. Additional tabs or views can be 

added to the new windows as well. 

How do I add a new view or tab? 
■ Click on any plus sign next to a tab and select the 

type of tab to add to the stack of tabs at that 

current location.  

■ To add a new tab to one of the four corners of a 

VarSeq window, right-click on a stash icon and 

select the type of tab to add. 

How do I visualize data in GenomeBrowse? 
■ To plot the variants, click on the plot button   

in the main tool bar and select Plot Unfiltered 

Variants. 

■ Similarly data from any numeric column and 

Sample Alignments from BAM files (if linked on 

import) can be visualized in GenomeBrowse 

through the plot menu on the main tool bar. 

How do I create my own annotation source? 
■ In a GenomeBrowse view, click on the Add data 

sources button  and in the lower left corner 

click on Convert…. 

How do I edit labels? 
■ Double-click on any filter card, filter container, filter 

chain, plot title or axis label to edit the text. 

How do I share a VarSeq project with a 

colleague?  
■ Anyone who has installed VarSeq can view existing 

projects. Have your colleague install VarSeq, and 

send them the entire project folder. 

■ They will be able to download any required 

annotation sources if they are publically available. 

■ Send with the project any proprietary annotation 

sources, or sources created locally. 

■ VarSeq Viewer allows free access to view projects, 

explore the filter chain and export results. 

Limitations include: 

■ New projects cannot be created 

■ New annotations cannot be added 

■ Existing projects cannot be saved 

■ Databases cannot be created or modified 

■ Many filter chain modifications are disabled 

How do I take notes or save important 

information about a project? 
■ You can either create a project note or connect to 

an Evernote account. To create a project note, add 

a Note view and select Open a New Note. 
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■ To connect to an Evernote, create an Evernote 

account if you do not already have one. You can 

find a quick link to create an account in the File 

menu. 

■ Once you have an Evernote account, you will need 

to authorize VarSeq to have access to your 

Evernote account. 

■ After that step, you can either select an existing 

note or open a new note. This will open a new 

window that can be docked where ever you would 

like in any open window for the project. 

■ Notes can be saved, copied or shared with other 

users. Links to sites in GenomeBrowse can be 

added to notes to zoom to that location. 

Using GenomeBrowse in VarSeq 

How do I add a plot? 
■ You can drag and drop any BAM, BED, TSF or VCF 

file directly into the GenomeBrowse view. 

Additionally, if a BED or VCF file is bgzipped you 

can drag and drop the BED.GZ or VCF.GZ file into 

the view as well. 

■ You can also stream BAM and TSF files by clicking 

on the Add button  in the top left corner of the 

GenomeBrowse view. From this dialog you can add 

data from a local folder, the Golden Helix public 

annotations server, or BAM files from a URL. 

■ You can change the default visible plots for Read 

Alignment (BAM) files by clicking on the 

GenomeBrowse view gear icon  and checking or 

unchecking the Coverage or Pile-up options. 

■ You can change where new plots are added in the 

Options dialog. By default new plots are added to 

the Top of the plot view, this can be changed to 

have plots added to the Bottom of the view. 

How do I navigate? 
■ There are two navigation modes in 

GenomeBrowse: 

■ In Navigation Pointer Mode , you can 

pan any plot or axis by holding down the 

left mouse button. Dragging with the right 

mouse button scales the plot. 

■ Zoom Mode  will give you access to the 

rubber band zoom feature. 

■ You can use the scroll wheel to zoom in and out in 

any mode. 

■ By default, all plots have y-axis fit-data or auto 

zoom enabled. To change the y-axis zoom mode, 

hover over a plot and click the zoom mode button 

on the right edge (labeled with a letter). 

■ You can jump to a specific region or gene by typing 

it into the Zoom Toolbar. This includes typing in a 

gene or transcript name. 

■ There is a zoom slider for the x-axis in the toolbar 

between the – and + buttons. These controls scale 

the x-axis on all plots. 

■ There are left and right arrows framing the Domain 

Scale. These controls pan the x-axis on all plots. 

■ Right-click before you complete a zoom selection 

to cancel. 

How do I see my previous view? 
■ Clicking the Back and Forward arrows  allows 

you to traverse zoom history. 

■ Right-clicking or holding the mouse button down 

on one of the buttons for a few seconds gives you a 

list of recent zoom history states, so that you can 

jump back by multiple steps. 

How do I move and resize plots? 
■ You can drag plots around in the view using their 

handles (at the left of a plot). 

■ To resize the plot, you can mouse over the handle 

(at the bottom of a plot) and drag up or down. 

How do I change how my data is displayed in a 

plot? 
■ In some plots, a gear icon will appear in the top-left 

corner when view options are available. Click on 

this gear icon to view plot-type specific options. 

■ If a view already contains the plot control panel, 

you just need to select a plot to have the control 

options update with those relevant to that plot 

type. 

■ To open the control panel, right-click on a plot and 

choose Controls….  
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How do I change the colors? 

■ Click on the gear icon  and click on the Color tab. 

■ Reference Mismatch defines the color of variant 

plots when zoomed out. 

What can I do with the mouse anchor? 
■ Right-click anywhere in a plot and choose Place 

Mouse Anchor to mark a location. 

How do I learn more about the GenomeBrowse 

features? 
■ For more help consult the VarSeq manual or visit 

www.goldenhelix.com/GenomeBrowse/online_help  

Mouse 

Double-click on a title, scale, or filter card label to edit it 

in-place 

Use the scroll wheel to navigate up or down in the view 

Clicking on filter cards, filter containers, column groups, 

and columns, as well as rows in the Table View and 

features in the GenomeBrowse view will display details 

and statistics in the Detail View 

In the Table View: 
Use the arrow keys to select variants and view in 

GenomeBrowse and in the Detail View 

Right-click on a row in the table view options for copying 

data from the row 

Left-click on a column to display a histogram for the 

column 

Double-click on a hyperlink to launch the web browser for 

that URL 

In GenomeBrowse: 
Use the scroll wheel to zoom in or out 

■ On canvas – affects x-axis only unless auto-zoom is on 

or a modifier key is used 

■ On scale – affects the scale axis only unless auto-

zoom is on or a modifier key is used 

 

 

Note for Mac OSX Keyboard Shortcuts 
■ Use the Command key instead of Ctrl 

■ Use the Option key instead of Alt 

 

Keys 

Alt + [Key] Menu access 

Ctrl + J Show download window 

 

F1 VarSeq Manual 

Alt + 5 Show all stashed views 

Alt + 1  Stash/unstash upper left corner 

Alt + 2  Stash/unstash upper right corner 

Alt + 3  Stash/unstash lower left corner 

Alt + 4  Stash/unstash lower right corner 

 

Ctrl + Alt + 1 Stash all but upper left corner 

Ctrl + Alt + 2 Stash all but upper right corner 

Ctrl + Alt + 3  Stash all but lower left corner 

Ctrl + Alt + 4  Stash all but lower right corner 

 

. (period) Switch table view to filter chain output 

Shift + .  Switch table view to filter chain input 

Del Delete selected filter cards or 

GenomeBrowse plots 

Ctrl + C Copy selected text 

Ctrl + A Select all (in any text box) 

Ctrl + Z Undo (in any text box) 

Ctrl + N New project 

Ctrl + O Open project 

Ctrl + S Save project 

Ctrl + Shift + S Save project as… 

Ctrl + W Close window 

Alt + C Cancel option dialog 

Alt + O OK option dialog 

http://www.goldenhelix.com/GenomeBrowse/online_help


 

 
 

      © 2015 Golden Helix, Inc. 6 

 

 

 


